Go Back   Train Horn Forums > Installation Help & Advice > Horn Kits
 Register

Reply
 
Thread Tools Display Modes
  #21  
Old 21st October 2011
Stinkypete's Avatar
Stinkypete Stinkypete is offline
Super Stinky!
 
Join Date: February 2009
Location: LONDON - UK
Posts: 2,793
Stinkypete is on a distinguished road
Default Re: Horns squeak every time i use them

Ermmmm simply send them back to HB headquarters.....They have a life time guarantee folks!!!
__________________
https://www.trainhornforums.com/showthread.php?t=6818

K5 AIRCHIMES ON A LITTLE NEMO VAN
8.5 GALLON AIR TANK
3 x VIAIR 400c COMPRESSORs
HORNBLASTERS MANUAL VALVE
2 x 1/2" SOLENOIDS
HORNBLASTERS 100w PA SYSTEM
100ft 2 CHANNEL REMOTE CONTROL UNIT

check out www.hornstaruk.co.uk TWO IN THE PINKY, ONE IN THE STINKY!!
Reply With Quote
  #22  
Old 27th December 2011
krayz krayz is offline
Junior Member
 
Join Date: August 2011
Posts: 5
krayz is on a distinguished road
Default Re: Horns squeak every time i use them

The lifetime guarantee doesn't cover this. What i did to fix the problem is just use the tuning screws. Also, i hooked up the horns to a different compressor with a regulator and lowered the maximum psi to where the horns didn't squeak but sounded great so, I'm now ordering a regulator for my in-car compressor to solve any future problem, and from my ears, I can't hear any difference in loudness within 20 psi. Hope this helps
Reply With Quote
  #23  
Old 30th April 2017
Horn dog Horn dog is offline
Newbie
 
Join Date: September 2016
Posts: 3
Horn dog is on a distinguished road
Default Re: Horns squeak every time i use them

Quote:
Originally Posted by krayz View Post
Hi I have the 228 shocker series horn kit. It worked fine for about 6 months with no problems. Now every time I use them when the tank is full the horns squeak then when the pressure lowers it sounds normal. I drain my tank 4-5 times a week. and was wondering if maybe its the solenoid? I don't know if its a filter inside there but whatever it is, is glazed over and brownish colored. Would changing that mat a difference? What would be causing my horns to squeak only at peak pressure but when the pressure lowers a little it goes to sounding normal? thanks
Ok here's a twist I have the same issues at the lower pressures! I run 200 off and 150 on and it seems as I get to the lower side it squeals. Then shortly after comp on and fills up and good till the bottom of the pressure switch limits ! I have the wolo chief horn and viair 300. Any suggestions, comments? Thanks !
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:47 AM.